




Apple and associated, not embedded, with the album by iTunes. I manually added the following text into the Comment field of each track, "Manually added
comment in iTunes for Norah Jones in ALAC."

Artist: Jack White
Album: Blunderbuss
Method: I ripped this album with iTunes set to import files using the AIFF Encoder and error correction. Album art was automatically downloaded from Apple and
associated, not embedded, with the album by iTunes. I manually added the following text into the Comment field of each track, "Manually added comment in iTunes
for Jack White in AIFF."

Artist: Lionel Richie
Album: Tuskegee
Method: I ripped this album with iTunes set to import files using the AIFF Encoder and error correction. Album art was added manually by selecting all album
tracks > Get Info > and dragging the image file into the Artwork window. This album art is embedded, not associated, into each track of this album. I manually
added the following text into the Comment field of each track, "Manually added comment in iTunes for Lionel Richie in AIFF."

Artist: The Little Willies
Album: For The Good Times
Method: I ripped this album with iTunes set to import files using the WAV Encoder and error correction. Album art was automatically downloaded from Apple and
associated, not embedded, with the album by iTunes. I manually added the following text into the Comment field of each track, "Manually added comment in iTunes
for The Little Willies in WAV."

Artist: The Doors
Album: The Doors (24 bit / 96 kHz)
Method: I downloaded this album from HDtracks in FLAC format and edited the metadata with dBpoweramp on a Windows PC. I then converted the album to M4A
Apple Lossless using dBpoweramp and imported the tracks into iTunes using the Automatically Add to iTunes folder. iTunes surprised me by importing the PDF liner
notes into the Books section of the program. I manually added the following text into the Comment field of each track, "Manually added comment in iTunes for The
Doors 24/96 in ALAC."

Prior to this conversion I copied my five album test music library from a Mac to the Aurender without any file format conversion or metadata adjustments. 

This is an image of the original library with some embedded and some associated metadata as viewed in iTunes.

This is an image of the original library with some embedded and some associated metadata as viewed on the Aurender S10. Notice there are only four albums
listed, two of which are missing album art. In this image The Doors and Lionel Richie albums display album art because it was embedded into the tracks manually
within iTunes. The missing album is from The Little Willies. This album was ripped into WAV files. iTunes doesn't support any metadata embedding into WAVs and
without metadata the Aurender can only arrange the album by folder. Thus navigating the folder menu allows one to view The Little Willies album. 



Step One: Prepare iTunes Music Library
A. Convert all WAV files to AIFF within iTunes.
B. Use Doug Adams' script to place album art in each album folder.

Step Two: Convert Files and Adjust Metadata
A. Configure dBpoweramp
B. Convert entire library

Step One: A. Convert all WAV files to AIFF within iTunes. If users don't have any WAV files this step can be skipped.

Configure iTunes Import Settings to Import Using: AIFF Encoder. Menu location is iTunes > Preferences > General > Import Settings...

Sort the iTunes Music by Kind thus grouping all WAV files together. If Kind is not visible click the View menu > View Options > Check Kind. Select all WAV files by
clicking the first WAV file, holding down the shift key, then clicking the last WAV file. All WAVs should be highlighted. Right-click or hold the Control key and click to
view the popup options menu. From this menu select Create AIFF Version. If the option says any other file format you've missed the previous instruction to
configure the import settings. When this conversion is complete there's no need to delete the original WAV files unless disk space is running low.



Step One: B. Use Doug Adam's script to place album art in each album folder.

This is the belt and suspenders approach that enables both embedding album art into each track and including the embedded picture file in the same folder a the
album. Some music servers prefer to read the album art picture file over reading the embedded album art tag. Having the picture file may provided better options
for metadata manipulation should another server require this and the file doesn't consumer much disk space. Again, the belt (embedded art) and suspenders
(picture file) approach.

Visit Doug Adams' website (Doug's AppleScripts for iTunes ) to download the free script and make a monetary donation to Doug for creating such a great tool.
Once the ZIP file is downloaded unpack it and double click the enclosed dmg file. The two files visible when launching the dmg file should be placed in the user's
Scripts folder. 

Users with OS X version 10.6.x and earlier can simply browse Finder to Macintosh HD/ Users/(your-username)/Library/iTunes/Scripts and drag the two files into the
Scripts folder. If the Scripts folder doesn't exist simple create the folder by selecting File > Create New Folder from the menu at the top of the window. Then drag
and drop the two files into the Scripts folder.

Users of OS X 10.7.x and newer must unhide the Library folder to move Doug's script into the right location. To unhide the Library folder click the menu option Go
at the top of the Finder window. If the Go option is unavailable click anywhere on the desktop to make it appear. After clicking Go, hold down the Option key to
unhide the link to the Library folder. Select Library the browse to iTunes. If a Scripts folder exists place the two files into that folder other wise create the Scripts
folder by selecting File > Create New Folder from the menu at the top of the window. Then drag and drop the two files into the Scripts folder.

If iTunes was open, close the application and relaunch. Otherwise simply open iTunes once the script files have been copied to the Scripts folder. Users should now
see the Script icon at the top menu. Selecting this icon reveals Doug's Save Album Art as folder.jpg script as pictured below.

Using Doug's Save Album Art as folder.jpg script is simple. Select all albums within iTunes. I use the Album view for this task. Then select the Script menu at the top
and click Save Album Art as folder.jpg. This selection will bring up the configuration options window. I change JPEG Compression to Low because JPEG compression
is lossy and reduces image quality. Then click the OK button and watch the progress via the horizontal popup window. When the Script is complete click the Quit
button. Users should check a couple album folders to make sure the new file titled folder.jpg is located among the individual tracks. Each album folder should
contain one folder.jpg file. Once this step is complete the iTunes music library is prepared for work with dBpoweramp.



 

Important Note: Before proceeding to the next step it's imperative that a Windows computer has access to the iTunes music files. Mac OS X uses the HFS+
format for hard drives. Unfortunately Windows is unable to read an HFS+ (Mac OS X Extended) formatted drive without special software. Users with music stored
on a Network Attached Storage (NAS) drive won't have any problems and can skip directly to step two below. All other users are likely storing their iTunes music
files on either the internal Mac hard drive or an external FireWire or USB hard drive in HFS+ (Mac OS X Extended) format. The solution to allow Windows access to
the iTunes music contain on HFS+ (Mac OS X Extended) drives is different depending on one's computer and where the music is stored. One of the following
methods should resolve the issue for nearly all users.

Computer: Mac running OS X 10.6 or newer and running Windows XP, Vista, or 7 via Boot Camp.
iTunes Music Stored: Internal or external FireWire or USB drive.
Solution: Apple currently includes HFS+ read only drivers with Boot Camp. Windows should be able to read the HFS+ drive as of May 2012. An update to the Boot
Camp drivers may be necessary.

Computer: Mac 
iTunes Music Stored: Internal hard drive
Solution: 1. Purchase an external USB drive. Format the drive as MS-DOS (FAT) using the built-in OS X Disk utility. Copy all iTunes music to this new external USB
drive, then connect the drive to a Windows PC. I recommend USB drives in this scenario because they can be used with an Aurender or many other Linux servers. 
Solution: 2. Use Mac OS X built-in File Sharing to share the iTunes music folder over a network. This is typically more difficult for new users. To share a folder open
System Preference click on Sharing and check File Sharing. The iTunes music folder must be added as a Shared Folder and at least Read Only access given to
appropriate users. Once this is done a Windows PC can connect to the Mac with access to the music files. 

Computer: Mac
iTunes Music Stored: External FireWire or USB drive formatted as HFS+ (Mac OS X Extended).
Solution: 1. Purchase an additional external USB drive. Format the drive as MS-DOS (FAT) using the built-in OS X Disk utility. Copy all iTunes music to this new
external USB drive, then connect the drive to a Windows PC. I recommend USB drives in this scenario because they can be used with an Aurender or many other
Linux servers. 
Solution: 2. Users with enough internal hard drive space available can copy the iTunes music folder to the internal drive, then proceed to use the external drive as if
it was new -> Format the external drive as MS-DOS (FAT) using the built-in OS X Disk utility. Copy all iTunes music to this new external USB drive, then connect the
drive to a Windows PC. 
Solution: 3. Use Mac OS X built-in File Sharing to share the iTunes music folder over a network. This is typically more difficult for new users. To share a folder open
System Preference click on Sharing and check File Sharing. The iTunes music folder must be added as a Shared Folder and at least Read Only access given to
appropriate users. Once this is done a Windows PC can connect to the Mac with access to the music files.

Note about virtualization software such as Parallels and VM Ware Fusion. I was able to read an HFS+ drive using Parallels which doesn't require rebooting into
Windows. However, my Windows virtual machine is my Boot Camp partition which uses the Apple HFS+ drivers. Parallels says reading and writing to a USB HFS+
drive is supported with use of SmartMount in the Parallels VM configuration. According to the user manual, "When you connect a storage device or volume, it is
mounted as a network drive. For example, a USB flash drive plugged in to your Mac will be accessible from both the /Volumes folder in Mac OS X and My Computer
in Windows."

Step Two: A. Configure dBpoweramp

The remaining steps must be done using a Windows operating system. Users without dBpoweramp can purchase and download the product from the dBpoweramp
Reference R14 page (Link ). In addition to the main dBpoweramp product users must also download a free codec utility from dBpoweramp called ID Tag Update
(Link ). Once downloaded simply open the exe file and click next > finish for the utility to automatically install into dBpoweramp.

Once installed open the dBpoweramp Batch Converter Start > All Programs > dBpoweramp Music Converter > dBpoweramp Batch Converter. The following window
should appear. At the top of this window click the Filter button. Scroll down to the bottom and un-check WAVE (.wav). This instructs dBpoweramp to skip the WAV
files in the iTunes music library that were previously converted to AIFF files.



In the left window pane browse to the folder containing the iTunes music files and check the box next to the folder. In the image below I selected the Music folder
as everything underneath that top folder contains music. The image also show all tracks automatically selected when the folder Music was selected. Once the
correct folder is selected click the Convert button. This will not begin the conversion rather it only leads to additional configuration.

The conversion configuration window pictured below is very important to the success of the entire process. Select FLAC in the Converting To: drop-down box. I use
Lossless Uncompressed as my Encoding selection and enable the After Encoding Verify Written Audio option. The Output Location is where to set the target drive
for the converted iTunes music files' final resting place. There is no need to convert to an intermediate location when converting directly to the Aurender
accomplished the same thing and is much quicker. Select the Dynamic radio button. Enter the location of the Aurender in the Folder box. The network location of
the Aurender S10 music folder is \\Aurenders10-us\hdd1\. This will likely be different on a different network using a different Aurender. Clicking the Browse button
will enable users to select their Aurender server and its hard drive (Example ). In the final box I recommend copying this text and pasting it directly into
dBpoweramp -> [IFVALUE]album artist,[album artist],[IFCOMP]Various Artists[][IF!COMP][artist][][]\[album]\[track] - [title] This string determines how the music
is stored in folders on the Aurender S10. For example a regular album will be stored as Artist\Album\Track Number - Track Name. A compilation album will be
stored as Various Artists\Album\Track Number - Track Name. Users can change this to whatever suits their needs. 

Earlier in this guide Doug's script was used to place album art into each album folder. The Options: DSP Effects / Actions window is where to configure dBpoweramp
to use this folder.jpg file to embed album art and to copy the file to the Aurender. Click Add > Add DSP Effect > Folder.jpg Preserve. Make sure the top box is
checked. I also add the .pdf extension in the Files With Extension box. This preserves all liner notes that are PDF files by copying them to the Album folders on the
Aurender S10. The Aurender doesn't support these PDF files, but the SOTm sMS-1000 does and future Aurender servers may also support PDFs. In addition to



copying the album art dBpoweramp must be instructed to embed the art into each file. To configure this click Add > Add DSP Effect > ID Tag Processing. Select the
Manipulation tab and enter folder.jpg in the box to the right of Import Album Art From. 

Optional: On the ID Tag Processing window it's possible to map metadata fields. For example it's possible to map the iTunes Comments field to the FLAC
Description field if needed. A reason for mapping such a field is for consistency across a music collection. Some of my files contain comment type information in the
Description field while others contain this in the Comment field.

Preserve jpg options

ID Tag Processing options

Final conversion configuration settings

Step Two: B. Convert entire library

All the dBpoweramp conversion options have been set during the previous steps. It's time to click the Convert button and follow the progress. The progress window
displays the percentage of files converted and the number of converted files. Near the bottom right of this window is a little down arrow. Select this arrow, click
Priority, then click Above Normal. This option gives dBpoweramp greater priority than other programs and some services running on Windows.



When the conversion is complete dBpoweramp may display a window with numerous error messages similar to the following two messages. These messages can be
ignored based on the file dBpoweramp attempted to convert. Looking closely at the files one can see the names start with ._Track Name Here. These files are only
used in OS X and remain invisible to end users unless they've configured the operating system to show hidden files. Windows has no problem seeing these files and
dBpoweramp mistakenly attempts to convert them with the rest of the files. The bottom line is files or error messages about files that start with a "._" prefix can be
ignored. I'm sure there is a way to exclude these files from conversion but Ii am unable to find the option. The image below is a screenshot from the Aurender iPad
application. All five albums have album art and metadata visible to the user as opposed to the missing art and information found when simply copying files from the
Mac to the Aurender S10.

Error converting to FLAC, 'M:\music\temp\Music\Jack White\Blunderbuss\._01 Missing Pieces.aif' to '\\Aurenders10-us\hdd1\ - ._01 Missing Pieces.flac'
Error first chunk unknown: [clAIFFHandler::ScanFile]

Error converting to FLAC, 'M:\music\temp\Music\Norah Jones\Little Broken Hearts\._07 4 Broken Hearts.m4a' to '\\Aurenders10-us\hdd1\ - ._07 4 Broken
Hearts.flac'
Unable to decode m4a file (is corrupt or not supported audio type).

Looking at this guide as a whole may be overwhelming to many readers. Much of the information is extremely detailed and adds to the length of the guide. I'm
trying to avoid leading tech un-savvy readers down the road of conversion only leave them high and dry with a poor explanation of a simple step. We've all been
there following a how-to guide when all progress stops because the author forgot to add a minor detail. Hopefully that won't happen with this guide. To prove this
type of conversion is easier than it may appear I created a video of me going through the steps from downloading the script to clicking the convert button. The
entire process is done in less than 2 minutes 30 seconds. 




